SSL Issuance Disruption
Incident Report for AutoPrint Software
Postmortem

We apologize for the service interruption that occurred earlier today.

There was a system wide glitch with the lets encrypt SSL service therefore there was a delay in SSL renewal. The initial report is available in the Let’s Encrypt community forum: community.letsencrypt.org/t/2019-02-29-caa-rechecking-bug/114591

If a renewal fails for whatever reason it will automatically reattempt renewal every 3 hours. After the cool off period elapsed the issue self corrected earlier today.

Although this is the first time we have ever experienced a problem with the SSL certificate authority, we will be implementing more checks prior to the certificate renewal process sometime this week with hopes of making these changes live prior to 3/7/2020.

Posted Feb 29, 2020 - 23:07 UTC

Resolved
Services are fully restored and they are considering this incident resolved. The initial report is available in our community forum: community.letsencrypt.org/t/2019-02-29-caa-rechecking-bug/114591
Posted Feb 29, 2020 - 05:59 UTC
Monitoring
They have deployed a fix and confirmed that it works. Service has been restored and they are monitoring for any further issues.
Posted Feb 29, 2020 - 05:25 UTC
Identified
They have identified the root cause and developed a fix. They are in the process of deploying and testing the fix.
Posted Feb 29, 2020 - 04:47 UTC
Investigating
Certificate issuance has been temporarily disabled while they investigate the problem.
Posted Feb 29, 2020 - 03:09 UTC
This incident affected: 3rd Party Integrations (Let's Encrypt).